System Center 2012 Operations Manager – Setup – Database and WMI provider

I was trying to install SCOM 2012 in my lab environment but at the database wizard in the setup I getting an error after checking the SQL server name and instance.

The error was that I was using an unsupported version of SQL Server or WMI provider was not working. That’s was very strange, because I’m using SQL Server 2008 R2 SP1 with CU6. This Service Pack and CU6 is recommended for SCOM 2012 (SP1 beta).

I got this error in the log file. This log file is located at C:\Users\%username%\Appdata\Local\SCOM\Logs\OpsMgrWizard.log.

OK, this is odd. I’m using SQL Server 2008 R2 with Service Pack 1 and CU6 and this version is supported by SCOM. This must be a WMI error then! After researching on the Internet I have found this tool to solve the problem

Run this tool for SQL server. Command is: mofcomp.exe “C:\program files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof”

You will get this message. After this message you are able to continue the setup. =D

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.